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Introduction to Geostatistics 

1.1 -  Geostatistics 
Data from geologic and hydrogeologic projects are typically sparse, in that there are large areas where no 
data exists.  Geoscientists often need to represent these geologic or hydrogeologic data in a qualitative 
manner by drawing contours on maps (e.g., elevation or thickness of geologic surfaces, groundwater 
levels or water quality data).  To generate these digital maps, existing data points are interpolated to a 
rectangular grid and contoured using automated procedures.  Often, these surfaces are needed as input 
data to a numerical model (e.g., top of an aquifer layer or thickness of an aquitard).  In these cases, 
interpolated values are needed at every point in the model grid.  In VIEWLOG, several methods are 
available for this interpolation process. 

Geostatistics is the study of the spatial correlation between variables. This rapidly evolving branch of 
applied statistics and mathematics offers a collection of tools aimed at understanding and modelling 
spatial variability (Davis, 1986).  Geostatistics attempts to quantify the degree of spatial variability 
(heterogeneity) as well as directional tendencies (anisotropy) within the data sets.  Typically, geologic 
data show a degree of spatial correlation that tends to decrease with distance.  Downhole data, (e.g., two 
gamma count measurements) may be similar in value when they are taken a few centimeters apart but 
would be quite different when taken metres apart.  Well data also tend to exhibit anisotropy in the degree 
of spatial correlation.  For example, we may expect the measurements taken between two wells 
separated by tens or hundreds of metres to be correlated as long as they are within the same geologic 
stratum even though samples separated by a few metres vertically are not correlated at all.  By 
understanding how the correlation of data values varies with distance and direction, we can better 
interpolate values at unsampled locations throughout our study area (i.e., the centre of each cell in a 
regular grid). 

Interpolation, even when using the most sophisticated geostatistical techniques, is not a substitute for 
obtaining good quality data.  Nor should these techniques be applied without conducting a thorough 
analysis of the data.  While there are some methods (e.g., inverse-distance or nearest neighbour) that 
can be used with little prior analysis, data values and trends in the values should be inspected visually to 
determine whether these methods are best suited for the particular application.  The more statistically 
based methods, such as kriging, require considerable analysis of the data before they can be applied 
correctly.  In all cases, the results of the interpolation must be examined for consistency with all the other 
available information and with regard to the principles of geology, sedimentology, and hydrogeology. 
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1.2 -  Grids and Gridding 
Gridding is the process of estimating the value of an attribute from isolated points onto a regularly spaced 
mesh, called a grid.  In VIEWLOG, the attribute’s values are estimated at the centre of each rectangular 
grid cell. 

Designing a proper grid is an important step in producing high-quality maps for presentation or model 
input data files.  Questions of how fine a grid to use, what to do in areas of limited data, and what is the 
most appropriate method of interpolation based on available data need to be addressed at this point.  
This discussion will introduce the basic concepts of grids, gridding and interpolation.  

1.2.1 -  What Is A Grid? 

Grids used in VIEWLOG consist of cells arranged in rows and columns.  The interpolation process 
assigns a value to each cell.  Typically, the grid will be created in such a manner that it covers the 
entire area of interest, plus a buffer.  As noted above, VIEWLOG grids are block centered (i.e., the 
interpolation point (node) is at the centre of each cell).  Square cells are commonly used, but 
VIEWLOG allows for rectangular cells with spacing that can vary between rows and columns.  In this 
way, it is consistent with grids used by the U.S. Geological Survey MODFLOW groundwater flow 
model.  A typical VIEWLOG grid is shown below where the red dots are the nodes the blue crosses 
are the locations of observed data.  The grid boundaries should ideally lie within the area defined by 
the available data to minimize the amount of data extrapolation. 

 

1.2.2 -  Grid Spacing 

The grid interval controls the detail that can be seen in the map.  Geologic features that are smaller 
than the grid spacing will not be represented well.  To accurately define a feature, the feature must 
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cover multiple grid intervals; thus the cell size should be small enough to show the required detail of 
critical small features.  Grid spacing should not be so large that multiple data points fall within the cell 
unless the data set is very large and averaging of multiple values per cell is desired.  A good rule of 
thumb is that the grid interval should be less than the average spacing between data points and cells 
should contain no more than one sample point.  A useful approach is to estimate the average data 
point spacing by eye and use it as the grid interval, rounded to an even increment. (Kachigan, 1986) 

There is, however, a trade-off: large grid cells produce maps quickly but at low resolution and with a 
coarse appearance.  Small grid cells produce high-resolution surfaces with smoother contours but they 
also increase the amount of data to be stored and take much longer computer processing times.   

There may be cases when grid extents or grid spacings are determined by external considerations, 
such as the design of the numerical model grid.  A finer grid could be used for the initial interpolation of 
the data and this grid could then be resampled to the model grid.  

1.3 -  Interpolation and Contouring 
The objective of contouring is to visually describe or delineate the form of a surface.  The surface may 
represent a structural surface (e.g., bedrock surfaces or isopach maps).  Contour lines usually refer to 
isolines of elevation.  However, any isoline can be called a contour, whether it depicts elevation, porosity, 
thickness, composition, or other property. 

Contour maps are a type of three-dimensional diagram compressed onto a flat, two-dimensional 
representation.  The X- and Y-axes usually correspond to the geographical coordinates, east-west and 
north-south, respectively.  The Z-axis typically represents the value of the attribute, for example: 
elevation, thickness, or some other quantity. 

Contour lines connect points of equal value on a map, and the space between two successive contour 
lines contains only points falling within the interval defined by the contour lines.  It is not possible to know 
the value of the surface at every possible location, nor can we measure its value at every point.  Thus, the 
purpose of contouring is to summarize large volumes of data and to depict its three-dimensional spatial 
distribution on a 2-D map surface (Kachigan, 1986). 

1.3.1 -  The Interpolation Process 

The mapping (interpolation) and contouring processes involve five basic steps.  

3. Identify the area and the attribute (parameter) to be mapped. 
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4. Design the grid to cover the area of interest. 

 
5. Visually check the data prior to interpolating.  This can be done by posting the numerical values 

of the data points at the locations and screening for “bad” values.  Another way is to post colour-
shaded symbols at the data points with the colour scale determined by the range of possible 
values.  Outliers can be screened visually by searching for values that are unusually high or low 
with respect to surrounding values. 

6. Calculate the interpolated values to be assigned at each grid node using an appropriate 
interpolation method. 

7. Use the estimated grid node values to draw contours.  In VIEWLOG, colour shading and the 
drawing of contours is an automated process. 
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Interpolation Methods 

Interpolation is the process of predicting the parameter value at unsampled sites from measurements 
made at point locations within the same area or region.  Predicting the value of a parameter at sites 
outside the area covered by existing observations is called extrapolation.  The example shown above 
involves interpolation to most cells in the grid and extrapolation to cells along the edge of the grid.  Most 
of the methods described here perform best when interpolating rather than extrapolating.  In the 
discussions below, we will refer to the gridding process as interpolation. 

2.1 -  Nearest Neighbour (Thiessen Polygons) 
Thiessen Polygons were first used in the climatology and geography fields.  Thiessen polygons are a 
graphical technique that can be used to describe the area of influence of a point within a set of points.  
This method begins by taking the first data point and drawing lines that connect it to the other nearby data 
points.  Once these lines are drawn, each line is bisected perpendicularly.  These bisectors are then 
connected to generate a polygon encompassing the first data point.  The procedure is then repeated for 
each data point.  The result is a set of Thiessen polygons.  The area contained within each polygon is 
closer to the data point on which the polygon is based than to any other point in the data set.  Grid cells 
falling within each polygon would then be assigned a value equal to the value at the data point. 

Fortunately, the Nearest Neighbor technique achieves the same results as the Thiessen polygon method 
without the need for any drawing.  The computer algorithm starts by selecting the first cell in the grid, and 
then searches through all the data points to find the one nearest to the grid cell.  The cell is assigned the 
value of the nearest data point.  The algorithm continues this process, working along the rows and 
columns of the grid, until all cells are assigned values.   
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2.1.1 -  Advantages of the Nearest Neighbour method  

The main advantage of the Nearest Neighbour method is that it is extremely simple to implement and 
it requires relatively little computational effort.   

2.1.2 -  Disadvantages of the Nearest Neighbour met hod 

The disadvantages of this method are: 

�  The resulting gridded surface is not smooth (i.e., there are sharp transitions between zones).  

�  Uniform properties are assumed for large areas 

�  Grid cells outside the network of data points are poorly extrapolated. 

2.2 -  Inverse Distance 
Most interpolation methods use a weighted-average technique, in which the estimated value, v, is  

 
1

n

i i
i

v wV
�

� �  

where wi are the weights and Vi are the values at the data points.  For example, if we wanted to assign 
the mean of the nearest 12 data points (as opposed to the value of just the nearest data point), the 
weights used would be equal to 1 because all points are given equal importance.  However, intuition tells 
us that the values at nearby data points should be given a more weight than the values at data points that 
are further away.  The Nearest Neighbour method can be thought of as an extreme case, where we 
assign a weight of 1 to the nearest point and a weight of 0 to all other points. 

The Inverse Distance methods assign weights to the nearby data points based on the reciprocal of the 
distance from the grid cell to the data point.  For example, a data point 10 metres from the grid centre 
would initially be assigned a weight of 1/10 or 0.1, while a point 100 m away would be assigned a value of 
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1/100 or 0.01.  The weights are then normalized (scaled) by the sum of all the inverse distances so that 
the sum of all the weights is equal to 1. 

The equation for the inverse distance method has the following form: 

1

1

1
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i i

n

i i
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d
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�
 

In the example below, the grid cell in the middle of the mesh is assigned a weighted average of the six 
neighbouring data points.  Data points that are farther away have less influence on the value that is 
assigned to the grid cell. 

 

The method has been generalized to include other weighting schemes such as Inverse Distance 
Squared  or Inverse Distance Cubed , where the weighting factor is proportional to the 1/d2 or 1/d3.  In 
these cases, the influence of points decreases more rapidly with distance.  VIEWLOG supports 1/d, 1/d2, 
1/d3, and 1/d4 weighting.  VIEWLOG supports the options of assigning weights to all data points (global 
estimation) or only to the nearest N data points (local estimation). 

2.2.1 -  Advantages of the Inverse Distance method 

The main advantages of the Inverse Distance methods are that they are relatively simple to implement 
and do not require significant computation time. 

2.2.2 -  Disadvantages of the Inverse Distance meth od 

The main disadvantage of this method is that there is no way of knowing beforehand which weighting 
factors to use and there is no measure of the error associated with the method.   
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2.3 -  Geostatistical Methods 
The value of a parameter at a point (e.g., the elevation of the top of a geologic unit, a groundwater level, 
or a contaminant concentration) can be thought of as the result of a combination of a number of random 
processes.  For example, groundwater levels measured in two wells may differ because of local variations 
in hydraulic conductivity and storage coefficients of the aquifer, infiltration rates, vegetative cover, 
precipitation history, and many other factors.  At the same time, it is recognized that if the two wells are 
located relatively close to one another, the water-level values are likely to be more similar than if the two 
wells are farther apart.  These types of random values, which have spatial correlation that decreases with 
distance, are called “regionalized variables”. 

Knowing that the data are spatially correlated can help us interpolate data values to the grid points more 
accurately, assuming that we could include information about the degree of continuity and correlation 
along with the values of nearby data points.  Kriging is a weighted-average method specifically designed 
to work with regionalized variables to produce accurate, unbiased interpolations that take into account the 
spatial variance in the data.  The most common means of quantifying and describing spatial variance is 
the variogram. 

2.3.1 -  Variance Analysis 

Assume, for a moment, that we have data sampled on a regular grid.  For example, we measure lead 
concentrations in soils at a site downwind of a smelter on a 5-metre grid.  We could calculate the sum 
of the squares of the differences in concentration between all pairs of sampling points separated by 5 
metres. Then we would calculate the sum of the squares of the differences in concentration between 
all pairs of sampling points separated by 10 metres.  Assuming that measurements at points close 
together are more similar that those further apart and assuming that we had the same number of pairs, 
the sum of the squares of the differences calculated for the 5-m separation should be smaller in value 
than for the 10 m separation.  Because the number of pairs at each separation distance may be 
different, we can normalize the sum of the squares by dividing by two times the number of sample 
pairs.  This normalized statistic is called the semi-variance ,� .  This statistic is used in the assigning of 
weights in the kriging method. 

The Experimental Variogram 

We could continue to calculate the semi-variance for pairs at other distances and plot the results as 
semi-variance versus separation distance  (as called the lag distance ).  This plot gives us a measure 
of how rapidly the spatial correlation decreases with distance.  At very large lag distances, we may find 
that the semi-variance begins to approach a maximum value.  This maximum value would correspond 
to the sample variance, v.   

The plot of semi-variance versus distance is called the experimental semi-variogram ( or simply, the 
variogram ).  Creating the variogram is easier if we have data mapped on a regular grid because we 
know beforehand all the possible separation distances.  More often, the sample locations are 
distributed randomly.  In this case, we need to first determine all the possible pairs of data points and 
their separation distances, we then need to define a reasonable number of lag intervals (e.g., 0 to 50 
m, 50 to 100 m, 100 m to 150 m and so on), and then we need to divide up all the possible pairs of 
data points into groups based on which lag interval they fall into.  Ideally, we should have a statistically 
meaningful number of data point pairs within each interval (e.g., 10 to 20 data points). 

The process of building the experimental variogram is illustrated below.  The seven data points in this 
example have 21 possible pair combinations.  Seven lag distances were defined as 0 - 1 km, 1 - 2 km, 
2 - 3 km, 3 - 4 km, 4 - 5 km, 5 - 6 km, and 6 - 7 km.   
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Next, the semi-variance  was calculated as: 

� �
n

ii
i

h

vv
2

1

2

� � 	
��  

where vi is the value of the i th data point and n is the number of pairs falling within the lag interval.  
The resulting experimental variogram, as plotted by VIEWLOG, is the blue line in the graph shown 
below.  The resulting experimental variogram is very erratic because there are only 21 pairs in total, 
and, consequently, only a few pairs in each lag interval.  However, it does show how the semi-
variance increases with lag distance. 
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Notes :  

In this sample data set, with only 7 data points, the resulting experimental variogram is 
erratic in nature due to the limited number of samples per lag.  Ideally, there should be 
at least 20 data points per lag. 

The variogram is often termed the semi-variogram because we actually plot the sum of 
the squares of the differences between data points divided by 2N. 

The Theoretical Variogram 

Because the experimental variogram may not be smooth, it is better to fit an idealized curve through 
the data for use in assigning weights in the kriging interpolation method.  There are a number of 
commonly used theoretical variograms  that can be fit to the experimental data.  For example, the 
figure above shows a linear variogram (red line) that has been fit through the experimental data   

Most theoretical variograms have the following properties that define the shape of the curve: 

�  Sill : Maximum value for the variance �  

�  Range: The distance at which the variogram reaches the sill.  This is the point at which the 
correlation drops to zero and the variance is equal to the sample variance.  At locations 
outside the range, all data points are given equal weights and the mean of the data is 
therefore best estimate of the value at that point. 

�  Nugget :  The offset from the x-axis.  Ideally, the variogram should go through the origin.  A 
variance at a lag distance of 0 indicates local variability or built-in systematic error. 

These three properties of the theoretical variogram are shown in a sample variogram shown below: 

 

Fitting the Theoretical Variogram 

You can adjust these three parameters independently when trying to fit a theoretical variogram to the 
experimental variogram.  Four different shapes of theoretical variograms are provided in VIEWLOG 
and are discussed below.   
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Linear Model 

The linear model describes a straight-line variogram with no sill or range.  It assumes that we are on 
the early (linear) portion of typical (e.g., spherical or exponential) variogram.  You can vary the slope of 
the variogram in VIEWLOG by adjusting either the sill or range property.   

Spherical Model  

The spherical model is one of the most frequently used models in geostatistics.  It is best used when 
the data is “patchy”, that is where there are areas with large values and areas with smaller values.  
The range represents the average diameter of the patchy areas (Webster and Oliver, 2001).   

Exponential Model 

The exponential model is similar to the spherical variogram in that it approaches the sill gradually.  The 
model is best used when the patches of larger and smaller values are random in size.  The range 
represents the mean diameter of the randomly sized areas (Webster and Oliver, 2001). 

Gaussian Model 

The Gaussian model shows that there is little variation within short distances of the data point and 
then variance increases rapidly with distance before approaching the sill asymptotically.  When using 
the Gaussian model, a small nugget must be added, otherwise, the kriging matrix becomes ill 
conditioned and results may be very erratic. 

2.3.2 -  Kriging 

Kriging is named after the South African engineer, D.G. Krige who first developed the method.  Kriging 
uses a mathematical model of the semi-variogram to calculate estimates of the surface at the grid 
nodes.  The kriging estimates are best linear unbiased estimates (BLUE) of the surface at the 
specified locations, provided the surface is stationary (i.e., the mean of the values is independent of 
location) and the correct form of the semi-variogram has been determined.  The procedures involved 
in kriging incorporate measures of error and uncertainty when determining estimations.   
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The following will introduce the conceptual outline of the technique: 

�  A quantitative measure of the variation of the data about its mean values is a statistical 
parameter called the variance . The variance of regionalized variables increases with 
distance from the sampled values.  In the kriging method, every known data point value and 
every unknown value (i.e., the value at the point you are interpolating to) has an associated 
variance based on the separation distance between points.  While the variance at the location 
of a known data point should be zero, the nugget effect allows for a finite, non-zero variance 
at a zero separation distance.  The variance increases with separation distance until a 
distance called the range, where the data point values are no longer correlated and the 
variance reaches its maximum value.   

�  Kriging calculates the value at the interpolation point using a weighted average of the values 
at the data points.  The optimal weights are determined by solving a set of simultaneous 
equations.  The coefficients in the equations are based on the theoretical variogram and the 
separation distance between points.  For example, the first coefficient in the matrix is equal to 
the nugget (or zero if there is no nugget) because the separation distance between point 1 
and point 1 is zero.  The second coefficient is equal to the variance at a distance equal to the 
separation distance between Data Point 1 and Data Point 2.  The third coefficient is equal to 
the variance at a distance equal to the separation distance between Data point 1 and Data 
Point 3.  The coefficient matrix is therefore only dependent on the separation distances 
between the known data points.  The coefficients on right-hand side (RHS) of the equation 
are based on the variance at the separation distances between the interpolation point and the 
known data points.  Thus, the first term on the RHS is the variance at the separation distance 
between Data Point 1 and the centre of the grid cell.  Another equation is added to the matrix 
to assure that the sum of all the weights is equal to one.  The matrix is solved using standard 
matrix-solving techniques to determine the interpolated value at the grid cell and the kriging 
variance (an estimate of the uncertainty in the estimation).  The process is repeated for each 
grid cell. 

�  As with most weighted average interpolation schemes, the weights determined in the kriging 
technique are larger for nearby data points than for more distant points.  The relative 
proportions are dependent on the shape of the variogram and the relative positions of the 
known data points.  A large nugget tends to reduce the influence of the nearby data points.  
Also, the individual weights of data points in a cluster are less than the weights assigned to 
single point at the same distance (Webster and Oliver, 2001).  

�  As noted, the terms in the coefficient matrix depend only on the variogram and the spatial 
distribution of the known data points.  When conducting “global estimation” using all data 
points, the coefficient matrix may be large but needs to be solved only once, leading to fast 
implementation of the method.  If conducting local estimation using the nearest N points, a 
new matrix needs to be constructed and solved for each grid cell (because the nearest N 
points to one cell may be different than the nearest N points to the next cell).  The time 
required to implement local estimation will vary depending on the value of N and the number 
of data points as well as the dimensions of the grid.  

Effects of Variogram Parameters on Kriging 

As the shape of the model variogram changes, so do the kriging results.  General rules are given 
below: 

�  Rescaling the variogram (to create a larger or smaller sill) has no affect on kriging estimate 
but changes the kriging variance 
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�  Increasing the nugget  component acts as a smoothing term during kriging (makes weights 
more similar also adds variance at a lag distance of 0, thereby allowing estimates near the 
known data point to vary from the data point value). 

�  A pure nugget effect (i.e., the nugget is equal to the sill) indicates that the data is randomly 
distributed and all data points are given equal weight. 

�  Increasing the range  tends to increase the weights of the more distance data points while 
reducing the weights of the closer points and leads to smoother maps. 

�  If the range is less than the distance to all the data points, all data points will be given equal 
weights and the interpolated value will simply be the mean of the data point values.  

�  The shape of the variogram near the origin influences the continuity of the interpolation 
process (i.e., the gentler the slope, the smoother the interpolation). 

Advantages of Kriging 

�  Kriging is an exact interpolator, that is, if we interpolate to the coordinates of one of the data 
points, the interpolated value will equal the data point value unless the variogram has a 
nugget effect. 

�  The kriging variance, which is determined as part of the interpolation procedure, is a 
measure of the reliability of estimation in different regions.  

�  The method is unbiased and minimizes overall estimation variance. 

�  Kriging requires the user to examine the spatial variability of the data to determine the best-fit 
variogram. 

Disadvantages of Kriging 

Kriging tends to produce smooth images of reality (like all interpolation techniques).  In doing so, short-
scale variability is poorly reproduced, while it underestimates extremes (high or low values).  It also 
requires the specification of a spatial covariance model, which may be difficult to infer from sparse 
data. 

Kriging consumes much more computational time than conventional gridding techniques, requiring 
numerous simultaneous equations to be solved for each grid node.  The preliminary processes of 
generating variograms and designing search neighbourhoods in support of the kriging effort can also 
require significant computational effort. 

2.3.3 -  Types of Kriging in VIEWLOG 

There are a number of kriging algorithms, and each is distinguished by how the mean value is 
determined and used during the estimation process.  

Quick Kriging:  The local mean varies, and is re-estimated based on the control points in the current 
search neighborhood ellipse. 

Full Kriging:  Typically called universal kriging, which is similar to ordinary (full) kriging, but used in 
conjunction with a trend surface 

Block Kriging: Estimating the value of a block from a set of nearby sample values using kriging. 

Fault Kriging: Uses assigned polyline(s) to indicate fault boundaries, using pair values on either side 
of the fault surface. 
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2.3.4 -  Statistics 

VIEWLOG can perform a statistical analysis of the known data.  This can also be used as a quick 
check that the Data Parameter and associated Data Source have been defined correctly.  If a trend 
analysis has been done and a trend type other than linear has been selected, the analysis is 
conducted on the de-trended data. 

The following statistics are computed: 

 Number of known data points : The number of data points in the data set. 

 Minimum Value : The minimum value in the data set. 

 First quartile (Q25) : 25% of the values are less than this value. 

 Median : 50% of the values are less than this value. 

 Third quartile (Q75) : 75% of the values are less than this value. 

 Interquartile range ( Iq): Third quartile minus the first quartile 

 Maximum value :  The maximum value in the data set. 

 Mean (zm): arithmetic average Szi
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Iq and s are measures of the data spread.  s is appropriate when the data are normally distributed.  Iq is 
less influenced by extreme values.  A value of 0 for ks indicates that the data are symmetric (i.e., the 
number of data values below the mean is similar to the number of data values above the mean).  A 
positive value indicates that there are a larger number of samples with values greater than the mean, 
while a negative value indicates that there a larger number of values smaller than the mean.  Estimating 
the variance of highly skewed data is difficult, and often a transformation of the data (such as taking the 
natural log or square root of the data values) is required prior to fitting a variogram model. 
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Geostatistics Tutorials 

3.1 -  Getting Started 

3.1.1 -  Setting up a New Grid 

For the purposes of the tutorials in this manual, we will be setting up a new, smaller grid in the 
Stouffville area.  This will allow us to examine different interpolation techniques in VIEWLOG. 

Tutorial 1. Creating a New Grid 
1. Open YPDT-CAMC basemap:  c:\oakridges\YPDT-CAMC BASEMAP VERSINON 1.map 

2. Make sure you are in World view. 

3. From the main menu, select Project Data > Define New Grid . 

4. Drag and draw a box on your map, as shown below.  The exact location of this box doesn’t matter 
because we will be editing the coordinates of it.  

 
5. The Grid Definition Menu  will open.  Set the Name to: Tutorial Grid – Geostats 

6. Set the X- and Y-Origin s and Extent s, and the No. of Columns  and Rows  as shown below: 
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7. You should see the grid that you’ve just created, as shown here: 

 
8. In this figure, the only visible Layers are: 

i. Regional roads (from internet).map 

ii. Text –Hamlets 

iii. GRID DEFINITIONS (The default Grid Definition Layer). 

3.2 -  Interpolation Methods 

3.2.1 -  The Nearest Neighbour Method 

In this tutorial we will use the Nearest Neighbour method to assign values to every cell in the new grid.  
The first step will be to create a new Data Parameter. 
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Tutorial 2. Using the Nearest Neighbour Method 

1. From the basemap, click the  icon to open the Project Manager. 

2. Highlight (select) Data Parameter 4, Regional Water Table.  

3. To create a new Data Parameter, click on the  icon and select Add New Data Parameter .  
Your new Data Parameter will be #5. 

4. Select Yes to replicate the settings from Data Parameter 4, and Yes again to insert the new 
Parameter into the list after position 4. 

5. Double-click on the new Data Parameter to open the Data Parameter window. 

6. Make sure the Parameter Number  at the top of the Data Parameter  window is set to 5. Regional 
Water Table.   

7. In the List tab, place a check beside this new Data Parameter.   

8. In the Name tab, rename this new Parameter: Regional WT – Geostats Tutorial - NN 

9. In the Post  tab, place a check in the checkbox called Show Symbol . 

 
10. Click on Apply , and you should see the locations of all the water table measurements on your 

basemap, as shown here: 
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11. In the Grid  tab, set the Link to grid  for this new Data Parameter to the grid we created 
previously:  Tutorial Grid – Geostats.   

12. Set the File  to c:\oakridges\grids\General Surfaces\Water Table VL Tutorial - geostats NN.GRD 

13. Under the Interpolation Options , set the Method  to Nearest Neighbour . 

 
14. Hit the Krige  button to perform the interpolation.  Select Yes to create the new GRD file for the 

results.   

15. On the Plan View  tab, click the Auto Scale  button.  Set the Increment  to 10.  Place checks in 
the checkboxes called Show Solid Color Fill  and Show Lines .   

16. Click on the Apply  button at the bottom of the Data Parameter window, and your basemap 
should resemble that shown below: 
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Note:  The resulting surface from the Nearest Neighbour method is ‘patchy’, with sharp 
changes in values from one zone to the next.   

3.2.2 -  The Inverse Distance Method 

In this tutorial we will use the Inverse Distance method to assign values to every cell in the new grid.  
We will create a new Data Parameter for these results. 

Tutorial 3. Using the Inverse Distance Method 

1. From the basemap, click the  icon to open the Project Manager. 

2. Highlight (select) Data Parameter 5, Regional Water Table – Geostats Tutorial - NN.  

3. To create a new Data Parameter, click on the  icon and select Add New Data Parameter .  
Your new Data Parameter will be #6. 

4. Select Yes to replicate the settings from Data Parameter 5, and Yes again to insert the new 
Parameter into the list after position 5. 

5. Double-click on the new Data Parameter to open the Data Parameter window. 

6. Make sure the Parameter Number  at the top of the Data Parameter  window is set to 6. Regional 
Water Table – Geostats Tutorial - NN.   

7. In the List tab, place a check beside this new Data Parameter.  Make sure all other Data 
Parameters are switched off. 

8. In the Name tab, rename this new Parameter: Regional WT – Geostats Tutorial - ID 

9. In the Grid  tab, make sure the Link to grid  box is set to:  Tutorial Grid – Geostats.   

10. Set the File  to c:\oakridges\grids\General Surfaces\Water Table VL Tutorial -geostats ID.GRD 
(This is a new file, so you will have to type in the file name). 

11. Under the Interpolation Options , set the Method  to Inverse distance . 

 
12. Hit the Krige  button to perform the interpolation.  Select Yes to create the new GRD file for the 

results.   

13. Click on the Apply  button at the bottom of the Data Parameter window, and your basemap 
should resemble that shown below: 
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14. Under the Interpolation Options , set the Order  to 2.   Hit the Krige  button to perform the 

interpolation.  Select Yes to overwrite the GRD file for the results.  Click on the Apply  button at 
the bottom of the Data Parameter window.  You have now applied inverse distance squared 
weighting to the data.  Compare the map with the one generated in step 12. 

3.2.3 -  The Kriging Method 

In this series of tutorials, we will perform a variance analysis on the data before kriging.    

Tutorial 4. Performing Variance Analysis 

1. From the basemap, click the  icon to open the Project Manager. 

2. Highlight (select) Data Parameter 6, Regional Water Table – Geostats Tutorial - ID.  

3. To create a new Data Parameter, click on the  icon and select Add New Data Parameter .  
Your new Data Parameter will be #7. 

4. Select Yes to replicate the settings from Data Parameter 6, and Yes again to insert the new 
Parameter into the list after position 6. 

5. Double-click on the new Data Parameter to open the Data Parameter window. 

6. Make sure the Parameter Number  at the top of the Data Parameter  window is set to 7. Regional 
Water Table – Geostats Tutorial - ID.   

7. In the List tab, place a check beside this new Data Parameter.  Make sure all other Data 
Parameters are switched off. 

8. In the Name tab, rename this new Parameter: Regional WT – Geostats Tutorial - Krige 

9. In the Grid  tab, make sure the Link to grid  box is set to:  Tutorial Grid – Geostats.   
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10. Set the File  to c:\oakridges\grids\General Surfaces\Water Table VL Tutorial -geostats Krige.GRD.  
(This is a new file, so you will have to type in the file name). 

11. Click on the Fit Variogram  button to activate the Variogram Fit window: 

 
12. In the Variogram Fit window, click on the Analysis Options  button on the right.  The Variogram 

Fit Options window will appear: 

 
13. Click on the Variance Analysis  button to create the Experimental variogram.  This may take a 

few minutes.  

Note:  The default value for the Maximum Distance  was selected based on twice the 
current value for the range.  The default value for the Number of Intervals  is set to 16.  
This means that between a distance of 0 and 10000 metres, there are 16 intervals or 
lag distances.   

14. To get a better idea of the variogram at larger distances, set the Maximum Distance  to 30000, 
and hit the Variance Analysis  button.  Notice that the variogram from 0 to 10000 is fairly linear.  
We will fit a linear Theoretical Variogram to this part of the curve.  Set the Maximum Distance  
back to 10000 and hit the Variance Analysis  button. 

15. Click on the Auto-Fit Variogram  button to get an initial estimate of the Theoretical variogram.  
Click Yes when prompted to accept the Auto-Fit Results.  The Theoretical variogram (Red) 
should show a reasonably good match with the Experimental variogram (Blue), as shown below. 
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16. You can manually change the slope of this linear variogram by adjusting the Sill and Range 

values in the upper right-hand corner.  The fit is quite good, so we will accept these values.  Click 
on the Update and Exit  button, and then click Yes to overwrite the previous variogram values. 

Tutorial 5. Using the Kriging Method 

In the previous exercise, we performed a variance analysis on the water table data.  Here, we will 
krige the data. Prior to doing the actual kriging, we will first perform a visual check of the data to see if 
we spot any obvious outliers (i.e., statistical anomalies) in the data set. 

1. On the List  tab, make sure all Data Parameters are unchecked, except for 7. Regional Water 
Table – Geostats Tutorial, which you created in the previous exercise.   

2. On the Post  tab, make sure Show Symbol  is checked, and set the symbol type to Filled Circle .  
Set the Color  to Gradient , and the Size to Scaled to value  (with a value of 50), as shown below: 
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3. Click Apply , and you should see your data points as shown below.  Note that the size and colour 
of each data point is scaled to the value.  Larger, red dots are higher values; smaller blue dots 
are lower values.  This is a useful way to spot outliers from your data.  Data points that you feel 
are outliers must be removed manually. 

 
4. In the Grid  tab of the Data Parameter window, make sure Parameter Number  is 7. Regional 

Water Table – Geostats Tutorial – Krige. 

5. Set the Method  to Full Kriging , and hit the Krige  button.  The kriging process will take a few 
seconds. 

 
6. Click Apply , and your basemap should resemble that shown here: 
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Tutorial 6. Calculating Error, Variance, Drift, Dri ft Error, Residual 

The Grid  tab in the Data Parameter window has an option for calculating different results from the 
kriging process.  These include: 

i. Standard Error 

ii. Variance 

iii. Drift 

iv. Drift Error 

v. Residual 

In this exercise, we will create a new Data Parameter, and calculate the Standard Error, which is equal 
to the square root of the kriging variance.  The results of this error analysis will be placed in the New 
Data Parameter. 

1. In the Project Manager, highlight Data Parameter 7. Regional Water Table – Geostats Tutorial – 
Krige. 

2. Click the  button and select Add New Data Parameter.  Select No, so that the settings of 
Parameter 7 are not replicated.  Select Yes to place this new Parameter immediately after #7 on 
the list. 

3. The new Data Parameter will appear as #8 on your list.  From the Project Manager, double-click 
on this new Parameter to open the Data Parameter window. 

4. On the List  tab, place a check next to this new Data Parameter, and make sure all other Data 
Parameters are unchecked. 

5. On the Name tab, set the Name to: Geostats Tutorial – Standard Error 

6. On the Grid  tab, link this new Data Parameter to: Tutorial Grid – Geostats.  Next, set the File to : 
c:\oakridges\grids\General Surfaces\VL Tutorial Geostats – Error.GRD 
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7. Change the Parameter Number  to 7. Regional Water Table – Geostats Tutorial – Krige, which 
we created in the previous tutorial. 

8. Click on the Krige Options  button.  In the window that appears, set the Standard Error to the 
Data Parameter we just created:  8. Geostats Tutorial – Standard Error, as shown below: 

 
9. Click OK to exit the Krige Options window.   

10. Back on the Grid tab, hit the Krige  button, and select Yes to overwrite the existing GRD file. 

11. You will also be asked to create the GRD file for the Error analysis.  Select Yes. 

12. When kriging is complete, go to the List  tab and uncheck all Data Parameters except for 8. 
Geostats Tutorial – Standard Error.  Highlight (activate) this Parameter. 

13. On the Plan View tab, click the Auto Scale  button, and check the box labeled Show Solid Color 
Fill .   

14. Click Apply  and your basemap should resemble the following: 

 
15. You can repeat this task for any of the other kriging options: 

i. Variance 

ii. Drift 

iii. Drift Error 

iv. Residual 
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Note:  The Drift and Drift Error are calculated only if a linear of higher-order trend (drift) 
has been specified.  This option can be selected in the Variogram Fit window by 
selecting a trend from the Order of Trend  drop-down box. 

Tutorial 7. Fault Kriging 

To demonstrate block fault, we will create a new grid with larger cells.   

1. From your basemap, select Project Data > Define New Grid  

2. Draw box on your map.  Select Yes to create the new grid. The Grid Definition Menu will open. 

3. Set the Name to: Tutorial Grid – Fault Kriging 

4. Fill out the rest of the Grid Definition menu as shown here: 

 
5. Click OK.  Select Yes to regenerate the grid lines, and Yes again to resample all existing linked 

gridded Parameters. (There are currently no Parameters linked to this new grid.  Your new grid 
should look like this: 

 
6. Open the Project Manager and highlight 3: Regional Bedrock Surface (masl). 
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7. Click the  icon and select Create New Data Parameter .  Select Yes to replicate the settings 
of Parameter 3, and Yes again to insert the new Parameter immediately after 3. 

8. Double-click on this new Data Parameter to open the Data Parameter window.  

9. On the List  tab, make sure all Data Parameters are switched off except for this new Parameter 4. 

10. On the Name tab, change the name to: Bedrock Surface - Fault Krige 

11. On the Grid tab, change Link to grid  to: Tutorial Grid – Fault Kriging.  Set the File  to 
c:\oakridges\grids\general surfaces\VL tutorial – Fault Kriging.GRD 

12. Draw 2 separate polylines, similar to those shown below.  Make sure both objects are selected 
(as denoted by a dashed-line box that surrounds both polylines, as seen below): 

 
 

13. Set the Method  to Full Kriging .  Set Extents  to Fault kriging using all selected fault 
polylines .  
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14. Click the Krige  button and select Yes to create the new GRD file.  The resulting gridded file is 
shown here: 

15. On the Plan View  tab, set the Contour Start  and Stop  to 100 and 500, respectively. Make sure 
Show Solid Color Fill  and Hill Shade  are checked on.  Click Apply .  Your result should 
resemble the figure below.   

 
 

 

Tutorial 8. Indicator Kriging 

Indicator kriging can be useful process to interpolate data that consists of only 0’s and 1’s.  The 
resulting interpolated surface is a probability surface.  All values on the kriged surface will be between 
0 and 1.  For example, if you had a query for chloride concentrations, you could add a field in your 
query where the well would be assigned a value of 1 if the concentration is greater than the Ontario 
drinking water objective (ODWO).   Wells with concentrations below the ODWO would be assigned a 
value of 0.  The resulting kriged surface will yield a map of the probability of exceeding the ODWO. 

In this example, we will modify the query that determines sand and gravel thickness.  If the thickness 
is greater than 5 metres, we will assign a 1.  Otherwise, we’ll assign a value of 0.  We will then create 
an interpolated surface for these values. 

1. Open up the Oakmaster Linked database 

2. Open the query: YPDT – S&G Thickness 2 in Design Mode. 

3. Add a new field called Indicator to this query, as shown below.  Set Indicator: IIF([Thickness] 
>5,1,0).  This states that a value of 1 will be assigned if Thickness is greater than 5.  Otherwise, a 
value of 0 is assigned to this new field. 
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4. Save this query, and go back to VIEWLOG. 

5. In the Project Manager, highlight Data Parameter 7. Regional Water Table – Geostats Tutorial – 

Krige, and hit the  icon and select Add New Data Parameter .  Click Yes twice to accept 
settings and place the new Parameter next on the list. 

6. Double-click the new Parameter to open the Data Parameter window. 

7. On the List  tab, make sure all Parameters are turned off except for this new one.  

8. On the Name tab, change the Name to VL Tutorial – Indicator Kriging. 

9. On the Source  tab, change the Table Name  to YPDT – S&G Thickness 2.  Set the Borehole 
Name to LOC_NAME, the Borehole ID  to LOC_ID, and Value 1 to Indicator, as shown below: 

 
10. On the Grid  tab, set the File to: c:\oakridges\grids\General Surfaces\Indicator Kriging.GRD 

11. Hit the Krige  button to krige the data.   

12. On the Plan View  tab, set the Contour Start  and Stop  to 0 and 1, respectively. 

13. Click Apply , and you should see a surface similar to that shown below.  Red/Purple areas are 
zones where the probability of encountering > 5 meters of Sand and Gravel is highest.  Blue 
zones are low probability zones. 
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The MODFLOW Management 
Module 

4.1 -  MODFLOW Management Module 

4.1.1 -  Introduction 

The VIEWLOG MODFLOW Management Module provides a set of pre- and post-processing functions 
for the U.S. Geological Survey (USGS) MODFLOW and MODPATH groundwater flow models.  A 
comprehensive water-budget utility is also included.  The MODFLOW module is fully integrated with 
VIEWLOG and it builds on the Well Database, Geologic Modelling, Mapping, Cross-Section and 3-D 
tools already contained within VIEWLOG. 

The MODFLOW module for VIEWLOG is not just a set of import/export tools; it is a powerful suite of 
groundbreaking tools for groundwater model data management.  This module is based on over 10 
years of work with MODFLOW, and includes over 100 modelling projects and thousands of model 
simulation runs. 

4.1.2 -  Need for the VIEWLOG Pre/Post Processor 

MODFLOW applications require that a finite-difference (FD) grid be designed to represent the aquifer.  
Aquifer properties, boundary and initial conditions, and spatially distributed stresses (e.g., recharge 
and evapotranspiration) are then defined for each cell in the FD grid.  These arrays of property values, 
boundary and initial conditions and stresses form the most important part of the required input data.  
Model results are provided primarily as arrays of hydraulic head values, drawdowns, and fluxes for the 
MODFLOW stress packages. 

In the past, preparing the input data arrays for FD grids was done manually using text editors and 
spreadsheet programs.  As computer capabilities improved, groundwater modellers created refined 
grids with larger numbers of rows and columns and the input data requirements increased accordingly.  
Preparing large data sets is a tedious process and consequently, simple graphical interfaces were 
designed to allow modellers to define properties by “pointing and clicking” on grid cells or blocks of 
cells.  Modellers could also import arrays of interpolated data from programs such as SURFER 
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(although SURFER requires uniform grid cells while MODFLOW allows variable-sized cells).  Similarly, 
contouring model results by hand and comparing simulated heads with observed data was 
manageable for small grids but difficult for larger grids.  Model post-processing programs were needed 
to generate graphics and statistics from MODFLOW output.  

Point and line sources, such as wells, rivers and drains make up the next most important part of the 
input data.  The locations of the wells, rivers and drains are specified within MODFLOW in terms of the 
row and column numbers.  Changing the grid, by adding a row or deleting a column for example, 
means that the row-column coordinates shift for all the data and that grid-based properties, such as 
the riverbed conductance term must be recalculated for cells that changed size. 

4.1.3 -  MODFLOW: The VIEWLOG Approach 

While there are many pre/post processors for MODFLOW on the market, most tend to link data entry 
directly to the FD grid.  Although this is consistent with the row-column-based coordinate system used 
in MODFLOW, it is far more useful to use actual spatial coordinates (e.g., UTM, State Plane 
Coordinate, or even a local site-specific system) to specify locations.  In developing VIEWLOG support 
for MODFLOW, a GIS-based approach was adopted, where point data (such as borehole and well 
locations), line-data (such as rivers and drains and model boundaries), and polygon data (such as 
aquifer property zones) are defined in world coordinates.  The origin of the grid and grid dimensions 
are also defined in world coordinates.  Model data sets are then linked to the model grid through 
VIEWLOG.  The advantages of this approach are that (1) model input data can be kept in a consistent 
coordinate system, and (2) the model input can be easily modified if the grid is later moved or refined, 
and (3) VIEWLOG can easily support multiple model grids within the same project (e.g., regional and 
site-specific-scale models sharing the same stream and borehole data). 

VIEWLOG generates all gridded data (Data Parameters) in a form that is compatible with MODFLOW 
because VIEWLOG also supports irregular grids.  VIEWLOG’s powerful data interpolation, parameter 
data editor, and Parameter Calculator functions can be used to create, modify and display these 
model input data arrays.  The VIEWLOG linkage to borehole databases allows model surfaces (e.g., 
aquifer tops and bottoms) to be generated by querying borehole geology and interpolating the 
elevation data.  VIEWLOG’s contouring, colour shading, and cross-section drawing tools can be used 
to analyze model results and spot problem areas.  For example, with the Parameter Calculator, it is 
easy to subtract the interpolated simulated water-table surface from the surface generated by 
interpolating observed water table elevations from monitoring wells and then colour-contour the 
difference to show areas where the model is over-predicting or under-predicting hydraulic heads.  The 
ability to view model geometry and simulated water levels along arbitrary section lines is another 
extremely useful feature that can help speed up the calibration process.  VIEWLOG can also be used 
to produce the high-quality graphical output needed for reports and public presentations. 

4.1.4 -  Relevant VIEWLOG Features 

VIEWLOG/GIS and VIEWLOG/PRO provide a powerful set of tools for building complex 3-D geologic 
models and for subsequent mapping of rock or fluid property variation within the geologic units.  These 
features are used extensively to help set up the data arrays that form the input to MODFLOW. 
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Data Parameters 

The Data Parameter  structure in VIEWLOG is used to organize, build and manage objects such as 
layer tops and bottoms, initial water levels, and aquifer properties.  For MODFLOW modelling, Data 
Parameters that represent gridded data are the most relevant.  For example, a bedrock surface can be 
generated by interpolating the “picks” stored in the borehole database to the model grid.  This Data 
Parameter could be then used to represent the top of an aquifer layer in a MODFLOW model.  Other 
model input data (such as transmissivity, storage, recharge, ET, initial heads, and the IBOUND array) 
are stored as Data Parameters.  VIEWLOG allows the user to link specific Data Parameters to specific 
MODFLOW model input array data sets to generate the “.BAS”, “.BCF”, “.RCH”, and “.ET” input data 
files.  Model results (such as hydraulic heads, drawdowns, and cell-by-cell flows) are also stored as 
Data Parameters.  Other Data Parameters, such as contour lines, may be used as secondary data in 
generating the gridded data. 

Grid Design 

Rectangular grids can be generated in VIEWLOG that are fully consistent with MODFLOW.  The grids 
can be refined in areas of interest by adding rows and columns.   

Interpolation and Geostatistics 

Several options are available for interpolation of point data (such as contact elevations, hydraulic 
conductivities, or static water levels in wells) to a grid.  These are described earlier in this document.  

Parameter Assignment 

Several methods can be used to assign property values to the grid.  The parameter assignment 
function can assign property values to the whole grid, to inside or outside selected polygons, or to cells 
within a specified distance from a selected line.  The Parameter Calculator function allows the user to 
write complex equations that can include multiple data parameters.  The Parameter Editor allows the 
user to change cell values on a cell-by-cell basis.  The look-up feature is another powerful way of 
assigning property values.  For example, aquifer property zones can be assigned numbers based on 
an imported bedrock geology map.  These zones can be then assigned transmissivity values, storage 
coefficients, and anisotropy ratios by creating a look-up table in MS-Excel or MS-Access. 

4.1.5 -  VIEWLOG Modelling Features 

Overview 

The MODFLOW Management Module addresses the modelling process with a data driven approach. 
VIEWLOG recognizes that with today’s powerful computers and fine model grids, data management 
and processing are the most critical aspects of modelling.  Modelers need database, mapping, 
gridding and contouring tools that are not simply targeted at a single model simulation. Complex model 
geometry, fine model grids and transient simulations demand a new level of data integration and 
management.  

For these reasons we call this module the MODFLOW Management Module, for it is not simply a pre- 
or post-processor.  Some of the features unique to VIEWLOG are outlined below. 
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Multi-Simulation Support 

Parameter Linking Layer 

VIEWLOG manages gridded parameter data in a manner that is independent of MODFLOW.  The 
user can then link, or "map" gridded parameters to the standard MODFLOW file inputs. This linking 
process is performed through a simple menu, and different linking sets can be quickly saved and 
reloaded.  

This approach recognizes that a modelling project is made up of multiple simulations, often with only 
small changes in input parameters.  This vastly simplifies the management of a complex set of 
simulations, because there is no need to duplicate the common input parameters.  In addition, there is 
no difference between input and output gridded parameters, so outputs from one simulation can be 
easily used as an input to the next.  

There is also no limit to the number of gridded parameters that can be managed in one VIEWLOG 
Project.  

Multiple Active Grids 

In addition to the Parameter Linking Layer, VIEWLOG also supports multiple active grids within the 
same project.  This simplifies the transition from regional-scale to local-scale modelling, as both 
regional- and local-scale grids can be active at the same time.  This greatly simplifies comparison of 
results from different models because you can simultaneously contour and overlay results from both 
grids.  This multi-grid feature is even supported on cross sections! 

In addition, the VIEWLOG grid equation processor can be used to develop equations that span 
multiple grids.  This makes translating gridded information from one grid to another very simple, no 
matter how the grids differ in cell configuration.  More details about the Grid Equation Processor are 
provided below.  There is no limit to the number of grids that can exist in one project.  

Model Geometry Construction Tools 

Overview 

Building the model geometry (gridded surfaces) is the most time consuming task in a modelling 
project.  VIEWLOG was designed specifically for "geologic modelling", in a manner that is fully 
MODFLOW compatible.  

VIEWLOG contains a number of tools for controlling the gridding process and fine-tuning the results. 
This recognizes that building a model often requires interpretation of sparse data.  Often, simply 
kriging all the known points is not sufficient.  To address this problem, VIEWLOG provides tools that 
can add “hydrologic insight” by supplying constraint or adding additional data such as digitized map 
contours to the gridding process.  VIEWLOG also has tools, such as the Parameter Calculator and the 
Parameter Editor that can be used to efficiently modify or edit the gridded values once the interpolation 
is complete.  

It is also important to note that VIEWLOG internally is based on MODFLOW compatible block-
centered, variable cell size grids.  This is significant because most other gridding and contouring 
packages (e.g., Surfer) can only work with uniform cell size, node-centered, grids.  VIEWLOG offers 
the following advantages:  

�  Cells are only added where necessary (grid refinement)  
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�  Interpolation is done to the center of the cell  

�  No translation between grids is necessary (no "smearing" of gridded data)  

�  Contouring is performed directly on the model results (no re-interpolation)  

VIEWLOG also fully supports grid refinement, so gridded parameter values are preserved when the 
grid is refined.  

Controlled Gridding 

3-D Gridding Control Polylines 

As noted, VIEWLOG includes tools that make it very easy to "control" the gridding process.  The user 
can simply draw a polyline on the map, assign an elevation or concentration, and incorporate that 
polyline into the kriging process.  The gridding process will then honour those values along the 
polyline.  This approach is much more efficient, and integrated, than simply adding "Ghost wells". 

Advanced Gridding Techniques 

VIEWLOG offers a range of interpolation techniques including nearest neighbour, inverse distance 
weighted interpolation, and point and block kriging.  Ordinary kriging and universal kriging (i.e., kriging 
with a drift) are both supported.  For example, first-order kriging can be used to honour and 
extrapolate linear trends often seen in water level data.  

Kriging of log-transformed data is also supported and is useful when contouring hydraulic conductivity 
and other aquifer parameter data that may have a lognormal distribution.  Logarithmic contouring, in 
which contour colors are distributed in log-space, is provided to produce a better visual representation 
of parameter data that can span several orders of magnitude. 

Database Driven Geometry Layer Picking 

All gridding functions are integrated with the database tools in VIEWLOG.  Data points are passed 
directly from the database query to the gridding function without the need for creating temporary XYZ 
ASCII files.  In addition to the integrated well data editor, hydrostratigraphic units can be picked 
directly on the cross section.  All picks go directly into the database table.  

Finally, gridding can be performed either from the database or from contour lines and spot elevations 
stored in the map.  R-Tree gridding allows data sets to exceed millions of data points.  

Fault Gridding and Polygon Zone Re-gridding 

The VIEWLOG gridding functions can be used to grid only cells within a user-drawn polygon (e.g., 
fault block) using only the wells that fall within that zone.  It is also possible to re-grid a polygon zone 
within the grid using all well points.  

Direct Grid Control and Grid Post-Processing 

Polygon Attribute Assignment: True Grid Independenc e 

VIEWLOG includes polygon attribute management functions that provide true grid independence for 
Data Parameters.  These tools allow the user to assign model properties to user drawn polygons and 
then map (or assign) those properties to cells.  This provides the attribute management functionality of 
a GIS as well as full integration with the gridding and contouring functions.  
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Attributes are mapped in vertical sequence, so overlapping polygons are handled correctly and there 
is no need to maintain a polygon topology network.  Functions are also available for individual cell 
value assignment and editing of the grid cell values.  

Grid Equation Processor 

Most groundwater modelers have a suite of small utility programs.  These small FORTRAN or BASIC 
programs usually perform some basic grid processing functions, and write data back out to an ASCII 
file.  VIEWLOG provides a powerful grid calculation tool that fully addresses this problem.  

The Surface Calculation  menu tool allows the user to write simple equations to edit, correct or 
change the gridded data.  New gridded parameters can be generated, or existing grids can be 
modified by these one-line equations. Features include:  

�  Conditional expressions : Equations can include conditional "If Then Else" clauses to only 
modify cells that meet specific criteria.  Nested conditional equations can be included along with 
logical tests (e.g., AND, OR, NOT, >, <, <>).  

�  Polygon limits : Processing can be limited to cells within, outside or near a polygon or polyline.  

�  Summations : Cell values can be summed to provide totals such as total flux into an polygon 
zone  

�  Area and Volume calculations:  Cell area and volumes can also be summed. 

�  Save and Reload equations : Finally, all equations can be saved as a script and reloaded for 
later use.  

A more detailed description of this Parameter Calculator is provided in the VIEWLOG User’s Guide. 

MODFLOW BCF/BAS Compatibility 

VIEWLOG can import any MODFLOW data set (BCF/BAS files), making it easy to load existing model 
simulations into VIEWLOG.  

VIEWLOG generates standard MODFLOW and MODPATH input files (BAS/BCF, RIVER and other 
stress package files), so you can use your existing tools and knowledge along with VIEWLOG.  

The MODFLOW Module for VIEWLOG includes compiled 32-bit Windows version of MODFLOW, 
MODPATH and a water budget program BUDPRN.  These fully support multi-tasking under Windows, 
and allow the user to continue working in VIEWLOG while the model is running.  

Advanced River/Stream Attribute Management 

Overview  

The representation of rivers, streams and drains in MODFLOW is critical to the simulation of the 
interaction between groundwater and surface water.  The conductance between a river and an aquifer 
is based on the river length, width, and bottom sediment properties within each cell.  In addition, the 
controlling river elevation, or stage, will vary from cell to cell.  In other pre-processors, the user must 
manually calculate the conductance, and manually assign it to each cell.  VIEWLOG provides powerful 
tools that vastly simplify the management and preparation of river, stream and drain input files. 
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River Attribute Management 

VIEWLOG uses the polyline attribute and drawing layer management tools to allow the user to assign 
properties and classify line segments based on their river properties.  The polyline drawing and node 
editing functions provide full control over the river, stream or drain position.  

Lakes and wide rivers (which span more than one cell) are managed in a similar manner to river 
polylines, except that the polylines are closed to form polygon zones.  Conductance values are then 
automatically calculated on the basis of cell area.  

Elevation and River Stage 

The controlling elevation (stage) of a river or drain can be automatically extracted from any gridded 
surface.  For example, a digital elevation model (DEM) surface re-sampled to the model grid can be 
used as a basis for assigning control elevations.  This saves having to manually assign a river stage to 
each river node. 

Presentation and Post Processing 

River flux values can be color contoured to visually present the flux results.  Options include log 
contouring and reverse color scales.  Because calculated river flux values are stored as a VIEWLOG 
Data Parameter, all of the parameter editing functions are available.  The Parameter Calculation tool 
can be used to convert total cell flux to flux per unit area by normalization based on individual cell 
area.  Flux per unit area is useful when evaluating discharge into lakes or large rivers.  The calculation 
function can also be used to sum the total flux within user drawn polygons. This allows sub-watershed 
analysis of recharge and discharge.  

Visualization and Presentation Tools 

Drawing Editor Integration 

The MODFLOW Management Module is accessed through the Map Editor, so you can produce report-
quality model result figures without the need for any other CAD or drawing tool.  The most important 
aspect of this integration is that the model results are never translated into another package.  A 
detailed description of the Map Editor is provided in the VIEWLOG User’s Guide. 

Irregular-path Cross Sections 

Some model packages allow you to look at results along cross sections parallel to rows or columns. 
Unfortunately, this is of limited value because you often need to draw sections down flow lines that 
traverse the grid.  VIEWLOG allows you to cut a section down ANY user-drawn, multi-point, polyline.  
Multiple sections can be viewed at one time.  

All observed/predicted water levels can be presented on section.  Boreholes and pathlines can also be 
"projected" onto the section, with full user control over the offset distance from the section.  

Fully Integrated 3-D Visualization  

VIEWLOG includes a fully integrated 3-D visualization system that allows you to go from model result 
to 3-D fly-through in seconds, without any data translation steps.  3-D Views can include:  

�  Full real-time fly-thoughts, including 3-D MODPATH pathlines, boreholes, surfaces, etc.  

�  Fence diagrams  
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�  Real-time cutaway mode  

�  Draping of air photos on ground surface  

�  Control over object transparency 

�  Record, edit, save, load and playback your flight path  

�  Save AVI movies or your flythrough  

�  Support for all OpenGL Hardware based graphics accelerators  

Please see the VIEWLOG 3-D GeoExplorer portion of the VIEWLOG User’s Guide for full details 
about 3-D visualization. 

4.2 -  Groundwater Modeling Overview  

4.2.1 -  Background 

Groundwater flow modeling involves solving the partial differential equation (PDE) for groundwater 
flow for a given set of boundary and initial conditions.  The flow equation can be thought of as a form 
of the mass balance (conservation) equation combined with Darcy's Law.  The flow equation can be 
solved with either numerical or analytical techniques.  Analytical techniques can provide an exact 
solution to the PDE but are limited to cases of simple aquifer geometry, regular boundaries, and 
uniform aquifer properties.  The advantage of analytical solutions is that an exact value for the aquifer 
head (or drawdown) can be determined for every arbitrary x, y, and z location in the aquifer.  The 
Theis equation for drawdown at a well is a well-known example of an analytical solution. 

Numerical methods, on the other hand, are based on the idea of substituting a set of algebraic 
equations for the derivatives in the PDE.  As such, they can provide only an approximate solution to 
the flow equation.  Their advantage is that (1) they can be applied to situations with complex aquifer 
geometry, irregular boundaries, and non-uniform aquifer properties, and (2) the large number of 
algebraic equations can be solved quickly using computers.  Their primary disadvantages are that (1) 
the aquifer heads are determined at only a select number of points in the aquifer, and (2) the accuracy 
of the solution depends on the number of points used to approximate the PDE and the techniques 
used in selecting these points. 

Note:  Groundwater modelling is a complex subject involving an understanding of 
hydrogeology, mathematics, numerical methods, and computer programming.  An 
excellent source of further information is Anderson and Woessner (1992). 

4.2.2 -  Finite-Difference Methods 

The most popular numerical method for solving the flow equation is the finite-difference (FD) method.  
The first step in applying this method is to discretize the model domain.  In simple terms, this means 
that the aquifer is represented by a grid of rectangular cells or blocks.  For example, one could start by 
overlaying a sheet of graph paper over a map of the aquifer (or the part of the aquifer) being studied.  
Each cell on the graph paper would represent a small volume in the real aquifer.  Multiple aquifer 
layers are represented by layers of finite difference cells.  Values for aquifer properties, such as 
transmissivity and storage coefficients, are assigned to each cell.  Values for sources and sinks, such 
as recharge, evapotranspiration, and well discharge, are also apportioned to each cell.  The 
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advantage is that each cell or groups of cells can be assigned different properties to represent the 
spatial variability of these properties in the real aquifer.  An example of a multi-layer aquifer system 
represented by a grid consisting of five rows, 9 columns, and 5 layers is shown below.  
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Inactive Cell Node
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Using the Darcy Equation one can approximate the flow across the right side of a particular cell as 
being dependent on (1) the average transmissivity in the area between the centre of this cell and the 
cell to the right, (2) the distance between the centers, and (3) the difference between the head at the 
centre of this cell and the head in the adjacent cell (see figure below).  Similar relationships can be 
written to approximate the flow across the left, front, back, upper, and lower, faces of this cell.  Under 
equilibrium conditions (steady state), a mass balance equation can then be written for each cell in 
which we sum up the flows across each face plus any internal sources or sinks and set it equal to 
zero.  The head values in the cells that satisfy the equilibrium conditions are unknown, but can be 
determined by solving the set of simultaneous equations. 

 

Boundary conditions are applied by modifying the mass balance equation for cells representing areas 
along the physical boundaries of the study area.  For example, if a model cell represents an area 
along the shore of a large lake with a nearly constant stage, we can treat the head of that cell as a 
known value for all simulation time.  Similarly, a cell along a no-flow boundary can be treated as if it 
has zero transmissivity and it will not contribute to flow in the rest of the aquifer. 

For non-equilibrium (transient) conditions we can set the sum of the inflows into and out of the cell to 
be equal to the change in the volume of water stored in the cell, defined as the storage coefficient 
multiplied by the change in head between the previous (known) head value at the start of a small time 
interval, � t, and the (unknown) head at the present time.  Again, we can determine the head values at 
the current time level by solving the set of simultaneous equations.  The model progresses through 
time by setting up and solving the equations for each consecutive time step, using the newly solved 
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heads as the previous (known) values for the next time step.  Once the head values in each aquifer 
cell are known, one can then derive other information, such as groundwater velocities and volumetric 
flow rates. 

The accuracy of the FD method is largely dependent on the number of cells used, their dimensions, 
and the size of the time-steps (for transient simulations).  Discussions on the numerical accuracy of 
the FD technique can be found in textbooks on numerical methods.  In simple terms, one can easily 
see that if a single cell is used to represent a 1 km by 1 km aquifer block, the head value at the center 
of the cell will only approximate the true head in the aquifer.  As more (i.e., smaller) cells are used to 
represent the aquifer, better approximations of the variability in aquifer properties, stresses, and heads 
will be possible.  Of course, a finer discretization (i.e., smaller cells) does not always result in a better 
solution, because uncertainty, or lack of data regarding the distribution of aquifer properties and 
stresses can preclude development of an accurate model. 

4.2.3 -  The MODFLOW Model 

Setting up and solving the finite-difference mass balance equations is a complex process.  
Fortunately, there are numerous computer codes developed by university and government research 
centres that can read in your aquifer data, set up and solve the flow equations, and print out the 
resultant heads. 

One of the most widely accepted codes of these codes is MODFLOW, a modular code that was 
developed by MacDonald and Harbaugh of the U.S. Geological Survey.  The code uses the finite-
difference technique to set up the flow equation and employs a variety of solution techniques to solve 
the simultaneous equations.  Add-ons to the basic code include additional solvers, a particle-tracking 
post code (MODPATH), packages for better simulation of stream-aquifer interaction (STREAM and 
MODBRANCH), packages for simulating hydraulic flow barriers (HFB), and enhancements to the basic 
equation setup routines (BCF2 and BCF3)  

MODFLOW Conventions 

Definitions of several commonly used MODFLOW terms are provided here: 

Module 

A Module is a subroutine in the MODFLOW code that is used to read, write, or process specific data or 
perform some specific computational functions (e.g., the subroutine WEL1AL is called to allocate 
storage (internal array space) for data needed to simulate pumping wells; WEL1RP is called to read 
and print the input data for wells). 

Package 

A Package is a group of modules that deal with a single aspect of the simulation (e.g., the Drain 
Package has modules (DRN1AL, DRN1RP, DRN1FM, and DRN1BD) which allocate memory, read 
and print input drain input data, add terms to the coefficient matrix and right-hand-side vector, and 
calculate the drain mass balance (budget) terms).  

Solver 

A Solver is a package used to solve the simultaneous equations generated by the FD method.  
Solvers are named after the particular numerical technique used (e.g., SIP uses the Strongly Implicit 
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Procedure, SSOR uses Slice Successive Over-Relaxation, while PCG uses the Preconditioned 
Conjugate Gradient method).  

IBOUND Array 

MODFLOW uses an integer array to define the boundary-condition type for each cell.  Specifically: 

IBOUND (K,I,J) >= 1: Cell is an active, internal cell 

IBOUND (K,I,J) <= -1: Cell is a constant-head cell 

IBOUND (K,I,J) = 0: Cell is an inactive cell 

where I and J are the row and column number, respectively, and K is the layer number. 

VIEWLOG Data Parameter arrays that are used to store the IBOUND array data must be 2-byte 
integers.  The data format is defined under the Grid  tab in the Data Parameter  menu, as shown 
below. 

   

Stress Package 

The Stress Package is a group of modules that represent the various types of source/sink terms, 
including point sources (wells), head-dependent leakage terms  (rivers, drains, streams, general head 
boundaries), and areal recharge and discharge (recharge and ET). 

Wells 

Wells are used to represent any point source/sink of water to the model.  By MODFLOW convention, 
the flow rate (QWEL) for pumping wells is negative.  QWEL for recharge wells is positive.  

River Cell 

A River Cell is a cell that contains a head-dependent source/sink term to represent a river reach.  The 
defining features of a river cell are (1) leakage is proportional to the difference between the hydraulic 
head in the aquifer and the specified river stage when the head in the aquifer is above the base of the 
riverbed and (2) leakage is proportional to the difference between the stage and riverbed elevation 
when the head in the aquifer is below the base of the riverbed and, thus, is not head-dependent.  
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Drain Cell 

A Drain Cell is cell that contains a head-dependent source/sink term to represent a reach of a 
groundwater drain.  The defining features of a drain cell are (1) leakage is proportional to the 
difference between the hydraulic head in the aquifer and the controlling elevation of the drain when the 
head in the aquifer is above the elevation of the drain, and (2) that no leakage occurs when the head 
in the aquifer is below the elevation of the drain.  

Stream Cell 

A Stream Cell is a cell that contains a special type of head-dependent source/sink term to represent a 
stream reach as defined in Prudic (1989).  The defining features of a stream cell are: (1) the stream 
stage is computed on the basis on inflow from upstream reaches, stream width, and Manning’s n 
(uniform flow equation), (2) leakage is proportional to the difference between the hydraulic head in the 
aquifer and the computed stream stage when the head in the aquifer is above the base of the 
streambed, (3) leakage out can occur when the head in the aquifer is below the elevation of the 
streambed if there is sufficient flow in the stream, and (4) flow to the downstream reach is equal to the 
upstream inflow plus any tributary inflows minus the leakage loss. 

General Head Boundary (GHB) Cell 

A GHB Cell is a cell that contains a head-dependent source/sink term to represent leakage from some 
external source of water.  The defining features of a GHB cell are (1) leakage is proportional to the 
difference between the hydraulic head in the aquifer and the specified head of the external source and 
(2) head-dependent leakage always occurs.  As an example, a GHB cell could be used to represent 
leakage from a shallow pond overlying an aquifer cell.  The rate of leakage would depend on the stage 
of the pond (assumed to be constant), its surface area, and the thickness and hydraulic conductivity of 
the bed material. 

Conductance 

Conductance is a lumped term used to represent the geometric and hydraulic properties of a 
streambed.  It is equal to the hydraulic conductivity of the streambed (K’) divided by its thickness (B’) 
and multiplied by the width and length of the stream reach within the FD cell.  VIEWLOG will 
automatically calculate the streambed conductance for a line segment that represents a river, drain, 
GHB, or stream on the basis of the specified width, K’ and B’. 

Recharge 

Recharge in the MODFLOW model is the net recharge per unit area to be applied to a cell.  There is 
no facility within MODFLOW or within any of the standard add-on modules to calculate net recharge 
from precipitation.  Adjusting the recharge values at boundary cells is one way to apply a specified flux 
at a model boundary. 

Evapotranspiration (ET) 

ET in the MODFLOW model can be thought of as the withdrawal of water from the saturated zone by 
plant root systems (sometimes referred to as Groundwater ET).  MODFLOW has no facility to 
calculate ET losses from the soil zone.  Instead, a maximum ET rate per unit area is specified along 
with an ET depth.  The rate of ET applied is at a maximum when the water table is at or above land 
surface and decreases linearly down to zero as the depth to the water table approaches the ET depth. 
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Steady-State Simulation 

MODFLOW can run either steady-state or transient (time-dependent) simulations.  Steady-state 
simulations are used to approximate long-term average or equilibrium conditions.  For example, a 
model can be run without pumping to simulate pre-development conditions in an aquifer or with 
projected pumping rates to determine equilibrium groundwater levels and stream discharge under 
future conditions.  Special cautions must be observed when running steady-state simulations.  For 
example, there must be at least one constant head or head-dependent leakage cell for the model to 
converge to a meaningful solution.  Aquifer storage properties are not used in steady-state 
simulations.  Steady-state simulations are often used to initially calibrate model transmissivity values 
and then transient simulations are used to calibrate storage properties. 

Transient Simulation Array 

Transient simulations are conducted by marching through time from an initial time (t0) to the final time 
(tf) in a series of time steps.  Groundwater levels will change over time from the initial conditions to the 
final conditions based on the magnitude of the stresses, aquifer transmissivity and aquifer storage 
properties (storativity).  For example, a model can be run starting with 1905 steady-state pre-
development conditions.  Historical pumping rates and net recharge values for each 10-year period 
can be applied and the model can simulate the change in water levels in wells at the end of each 
“stress” period until the present.  Once the model is calibrated to match the historic record, it can be 
used to predict response to various future water-use and recharge scenarios.  Model results can be 
very sensitive to the size of the time step, especially if large changes are applied at the beginning of 
the stress period. 

Stress Period 

A Stress Period is the time period over which model stresses are assumed to be constant.  For 
example, a transient simulation could be run with different values of monthly net recharge and 
pumping rates.  MODFLOW reads the stress information for the first stress period along with all the 
other aquifer property information.  New stress information is read in for all stress packages at the end 
of the first and subsequent stress periods.  A value of –1 must be read for the input variable ITMP for 
stress packages that don’t change between stress periods (for example, if drain properties are 
constant during a simulation of monthly stress periods, a value of –1 will be read in for each period).  A 
steady-state simulation has only one stress period.  

Time Step 

Each stress period is discretized into one or more time steps per stress period.  The flow equations 
are set up and hydraulic heads are determined at the end of each stress period.  While there are no 
set rules for determining the required number of time steps per stress period, the number usually 
depend on the relative “shock” imposed on the model at the beginning of the stress period.  For 
example, turning on or off of a large well to represent a pump test may require time steps on the order 
of seconds to correctly simulate drawdown response.  Slight changes in monthly recharge rates may 
require a one-week time step to represent head changes over the stress period.  Time steps can also 
be adaptive (i.e., of variable size).  MODFLOW allows the user to specify an initial time step size and a 
multiplying factor (e.g., 1.01 or 1.1) for subsequent time steps.  VIEWLOG can calculate these 
parameters based on the number of time steps per stress period.  A variable time step can help the 
model deal better with large changes in applied stresses.  The best way to verify that the correct time 
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step has been specified is to re-run the simulation with a smaller step size and see if the difference in 
results is significant.  A steady-state simulation has only one time step.  

Transmissivity 

Transmissivity is defined as the hydraulic conductivity multiplied by the aquifer thickness.  MODFLOW 
typically expects transmissivity values rather than hydraulic conductivities.  These can be pre-
calculated by VIEWLOG using the “Parameter Calculator” from hydraulic conductivity data and aquifer 
layer tops and bottoms.  Alternatively, a Type 3 layer (confined/unconfined layer) can be specified so 
that MODFLOW reads in layer tops, bottoms, and hydraulic conductivity values and calculates 
transmissivity internally.  To simulate unconfined (water-table) conditions, MODFLOW calculates an 
effective transmissivity based on the latest estimate of saturated thickness (aquifer head minus aquifer 
base elevation) and hydraulic conductivity. 

Vertical Conductance 

Vertical Conductance is a lumped term used to represent the geometry and hydraulic properties of the 
soils between cells in adjacent model layers.  In a fully 3-D model, the vertical conductance represents 
an average vertical hydraulic conductivity divided by the distance between the midpoints of the two 
cells.  For a quasi-3-D system, the vertical conductance represents the vertical hydraulic conductivity 
of just the confining unit separating the two cells divided by its thickness.  Where both confining unit 
and the aquifer layers are of similar hydraulic conductivity, the full term is given by: 
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where z1 is the thickness of Layer 1, Kv1 is the vertical hydraulic conductivity of Layer 1, z2 is the 
thickness of Layer 2, Kv2 is the vertical hydraulic conductivity of Layer 2, K’ is the hydraulic conductivity 
of the confining unit and B’ is its thickness.  The vertical hydraulic conductivity, Kv, is related to the 
horizontal value through the vertical anisotropy factor. 

Primary Storage 

For confined layers, Primary Storage is used to represent the confined storage coefficient of the 
aquifer.  For the uppermost layer in an unconfined aquifer, the primary storage coefficient represents 
the specific yield. 

Secondary Storage 

For an aquifer that can undergo a transition from confined to unconfined conditions (Type 2 or 3), the 
Primary Storage is used to represent the confined storage coefficient of the aquifer while the 
Secondary Storage property represents the specific yield. 

Velocity 

MODFLOW results can be analyzed to calculate q, the Darcy flux (flow per unit area of aquifer), 
because effective aquifer porosity (n) is not defined for MODFLOW simulations.  The average 
groundwater velocity, v, is given by v = q/n and represents the average velocity of a conservative (i.e., 
non-adsorbed, non-reactive) groundwater solute. 
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Limitations of MODFLOW 

While VIEWLOG can limit some of the more tedious aspects of groundwater model development and 
processing of model results, it in no way lessens the requirement that the model application be well 
posed, that boundary conditions be specified correctly, and that reasonable values for aquifer 
properties and stresses be defined.  The rule of “Garbage In = Garbage Out” still applies. 

MODFLOW does very little in the way of checking for data inconsistency.  More likely, MODFLOW will 
crash, fail to converge, produce large mass-balance errors, or yield unreasonable hydraulic head 
values if incorrect input data are supplied.  While VIEWLOG has some data checking functions built-in 
to spot errors in aquifer geometry, VIEWLOG does not check on the reasonableness or completeness 
of the input data.  The pre-and post-processing utilities, however, do go a long way towards making it 
easier to spot errors and track down the cause of problems with MODFLOW. 

Note: MODFLOW requires that all data be provided in a consistent set of units.  That is, 
if transmissivity is specified in m2/d, than recharge must be in m/d.  MODFLOW does no 
internal conversions or checks for consistency.  The time unit specified in the *.BAS file 
and in the VIEWLOG main MODFLOW control menu just affects the labels printed out 
in the MODFLOW listings. 
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The MODFLOW Sample Problem 

5.1 -  Introduction 
The purpose of the VIEWLOG/MODFLOW tutorial is to provide an overview of how VIEWLOG can be 
used as a pre- and post-processor for the USGS MODFLOW groundwater flow model.  It is assumed that 
the user is familiar with the MODFLOW code and its data requirements, as opposed to simply being 
familiar with other pre/post processors.  For more information on groundwater modelling, refer to an 
excellent text by Anderson and Woessner (1992).  For a more detailed discussion of MODFLOW, please 
refer to the MODFLOW documentation McDonald and Harbaugh (1988).  For this tutorial, you will need 
two files: 

1. sample.dxf – Base map. 

2. sample.mdb – Database which contains borehole data. 

These two files are in your c:\oakridges\MODFLOW Tutorial\ directory. 

5.2 -  Getting Started 
In this section, we’ll set up the basemap and generate the grid for MODFLOW 

Tutorial 9. Importing a DXF Base Map 
1. Start VIEWLOG. 

2. From the main menu, select File > New Drawing .  You will see a blank white page. 

3. Select File > Import/merge . 

4. Select c:\oakridges\MODFLOW Tutorial\sample.dxf to import the base map. 

5. When the DXF File Import window appears, click OK 

6. Highlight the Wellfields, Aquifer Extent, Surface Water layers from the DXF Drawing Layer 
Selection  window.  (Use the Ctrl  key and the mouse to highlight multiple selections) and click 
OK. 

7. Save the Map file: select File > Save , and enter “Sample.map” 
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Tutorial 10. Create a VIEWLOG Project 
1. Select File > Project > New Project , and in the window that appears, enter “Sample.prj”.  Make 

sure you save the project in your working directory. 

2. Link the current map to a project by selecting File > Project > Link MAP to Project  and click 
OK. 

5.3 -  Grid Generation 
Now that we have imported the DXF file and linked it to a project, we will generate the MODFLOW 
grid. 

Tutorial 11. Create a New Layer for the Grid 
1. Open the Layer Control menu. 

2. When the Layer Control menu appears, move the mouse to the last layer (layer 4 – 

Surface_Water) and select the  symbol to add a new layer. 

3. Call this layer “Grid”. 

4. Right-click on this layer, and select Set to current Grid Definition layer . 

5. While we’re in the Layer menu, we’ll create layers for Data Parameters and Data Sources. 

i. Highlight the Grid layer and hit the  icon to add a new Layer.  Name this Layer Surfaces.  
Right click this new layer and select Set to current Parameter Layer.  

ii. Repeat this process.  Create a new layer called Boreholes, and set it as the current Data 
Source layer. 

Tutorial 12. Create the Grid 
1. From the main VIEWLOG window, select the Project Data > Define New Grid  menu item.   

2. Using the mouse, left-click and drag a box to define the extent of the new grid.  The exact 
dimensions of the box are not important at this time, because we will be editing these values 
manually. 
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3. Select Yes to create the new grid.  You may encounter an error message; hit OK to bypass this 
warning. 

4. In the Grid Definition Menu , fill in the parameters as shown in the following figure and listed 
here: 

i. Name: 15 x 15 MODFLOW grid 

ii. Make sure there is a check beside Show grid lines , so that the grid is shown. 

iii. No. of Columns : 15 

iv. Rows : 15 

v. Set the X, Y origin  to 0,0 

vi. Set the X, Y extent  to 75000, 75000 

vii. Select OK 

 
5. You should see a series of evenly spaced horizontal and vertical grid lines, as shown in the figure 

below. 

 

5.4 -  Setting up VIEWLOG Data Parameters for 
MODFLOW Layers 
VIEWLOG Data Parameters can be set up to define MODFLOW arrays.  In this section, we will create 
Data Parameters for the tops and bottoms for each of three MODFLOW layers. 

Tutorial 13. Setting up the Top of Layer 1  
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1. Open the Project Manager and hit the  icon and select Add New Data Parameter .  Click 
OK. 

2. Double-click on this new, unnamed Data Parameter to open the Data Parameter window. 

3. In the List  tab, make sure the current Data Parameter  is active by adding a check to the box on 
the left. 

4. In the Name tab, name this Data Parameter  “Layer 1 Top” 

5. We will generate a topographical surface based on some data that exists in the database called: 
Sample.mdb: 

i. In the Source  tab, select Simple x, y, value query for the Source Type   

ii. Click on the blank box for DB File Nam e, and select Sample.mdb 

iii. Click Refresh  

iv. Select the Table called “Topo” 

v. For X, select the ‘X” field, and for Y, select the field called “Y” 

vi. For Value 1, select the field called “Z”. 

vii. Click Apply  

6. To view the data points, select the Post  tab.  Check the Post Value  and Show Symbol  boxes, 
and click Apply . 

7. To contour these data: 

i. Select the Grid  tab, and in the Link to grid  box, select the “15 x 15 MODFLOW grid. 

ii. In the File  box, click the  button and enter “Layer 1 Top.grd” for the file name. 

iii. To generate the grid, select Krige , and click Yes to generate the kriged grid. 

iv. To view the contours, select the Plan View  tab and click on the Auto Scale  button.  Then 
check the Show Solid Color Fill  button and then click on Apply  at the bottom of the window.  
Your surface should look like this: 

 
8. For now, we will turn off the data points: 
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i. Select the Post  tab and uncheck Post Parameter 1  and Show Symbol , and then click on 
Apply . 

9. Click on OK to exit the Data Parameter window. 

Tutorial 14. Setting up the Bottom of Layer 1 

The bottom of Layer 1 will be set to a constant value of –150 feet (i.e., 150 feet below ground surface): 

1. Open the Project Manager. 

2. Highlight Data Parameter 1 and hit the  icon and select Add New Data Parameter .  Select 
No twice.  Click OK. 

3. Double-click on this new, unnamed Data Parameter to open the Data Parameter window. 

4. On the List  tab, uncheck Layer 1 Top, and check this new Data Parameter. 

5. Select the Name tab, and make sure that the current Parameter Number is “2”.  You can verify 
this at the top of the Data Parameter  window.  From the Name tab, call this Parameter “Layer 1 
Bottom”. 

6. Skip over to the Grid  tab and link this Data Parameter  to the grid called “15 x 15 MODFLOW 
grid”, and name the grid file “Layer 1 bottom.grd”.  Make sure you specify this grid file within your 
working directory. 

7. Click on Apply , and then OK to close the Data Parameter  window. 

8. To assign a constant value to this Data Parameter , select Tools > Parameter Calculator .  Here, 
we want to set Parameter 2 (Layer 1 Bottom) equal to a constant value of –150. 

9. Start by double clicking on Parameter 2. Layer 1 Bottom from the list of available parameters.  
You’ll notice that the Equation  line will be updated with PM(2) 

10. In the Equation  line, add “=-150” to the end of the equation, as shown in the following figure.  

 
11. Click on Execute . 

12. Select Yes to generate the grid. 

Tutorial 15. Setting up the Top and Bottom of Layer  2 

In a manner similar to that described above for the bottom surface of Layer 1, repeat the process for 
the top and bottom of Layer 2.  Set the top of Layer 2 to –160, and set the bottom of Layer 2 to –200.  
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Name the top and bottom for Layer 2 “Layer 2 Top” and “Layer 2 Bottom, respectively.  For the grid 
files, call the top and bottom files “Layer 2 Top.grd” and “Layer 2 Bottom.grd”, and make sure you 
create these grid files in your working directory. 

Tutorial 16. Setting up the Top and Bottom of Layer  3 

In a manner similar to that described above for the bottom surface of Layer 1, repeat the process for 
the top and bottom of Layer 3.  Set the top of Layer 3 to –210, and set the bottom of Layer 2 to –260.  
Name the top and bottom for Layer 3 “Layer 3 Top” and “Layer 3 Bottom, respectively.  For the grid 
files, call the top and bottom files “Layer 3 Top.grd” and “Layer 3 Bottom.grd”, and make sure you 
create these grid files in your working directory. 

It is good practice to save your work regularly.  From the File  menu, select Save, and click Yes to 
overwrite existing files. 

5.5 -  Setting up VIEWLOG Data Parameters for 
MODFLOW Boundary Conditions 
In MODFLOW, the IBOUND array  is an integer array that is used to boundary condition type for each 
cell.  The IBOUND array must be defined for each layer.  Each cell must be defined as one of the 
following: 

�  IBOUND = 0 – Inactive cell 

�  IBOUND = 1 – Active cell 

�  IBOUND = -1 – Constant Head cell 

In this section of the tutorial, we will create a VIEWLOG Data Parameter for the IBOUND array in each of 
the three MODFLOW layers. 

Tutorial 17. Setting up the IBOUND array for Layer 1 – Step 1 

In Layer 1 – the uppermost layer – all cells will be Active, except for the left-most column of cells, 
which will be set as Constant Head cells, to represent the Lake.  This will be done in two steps: (1) 
First set IBOUND in all cells in Layer 1 to a value of 1, (2) Set the left column of cells to a value of –1. 

1. Open the Project Manager. 

2. Highlight Data Parameter 6 and hit the  icon and select Add New Data Parameter .  Select 
No twice.  Click OK. 

3. Double-click on this new Parameter to open the Data Parameter window. 

4. In the Name tab, enter “Layer 1 IBOUND” in the Name window. 

5. In the Grid  tab: 

i. Select “15 x 15 MODFLOW grid” in the Link to grid  box. 

ii. In the File  box, enter a file name “Layer 1 IBOUND.grd”. 

iii. In the Format  box, select “Integer (2byte)”  (NOTE: This is important! ) 
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iv. Click on Apply , then OK. 

6. Select the Tools > Parameter Calculator  menu item. 

7. In the Equation  box, delete the equation that is shown, and type: PM(7)=1, as shown below: 

 
8. Click Execute  and select Yes in the window that appears, to generate the new grid file. 

Tutorial 18. Setting up the IBOUND array for Layer 1 – Step 2 
1. Draw a polygon that encompasses this column of cells: 

i. Select Draw > New Polyline .  

Note:  You can also start drawing a new polyline by first clicking on the  icon, or by 
using the shortcut CTRL-P. 

ii. With the mouse, left-click and drag a box around the cell-centres of the left-most column of 
cells.  Once you have encompassed the cells, right-click the mouse and select Display 
Properties  to bring up the Object Attributes  window.  Check on the “Closed path  box, and 
make Fill Pattern  “Hollow”.  Click OK. 
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2. Make sure the polygon you’ve just drawn is the current selected object.  If it is already selected, 
there will be a dashed-line rectangle around the polygon, as shown in the figure above.  If not, 
select the Edit > Select objects   

Note:  You can also active the Select objects  function by using the short-cut F2, or by 
clicking on the  icon.   

3. Click on the polygon to select it.  Make sure you select the polygon you’ve just drawn, and not the 
blue ellipse that represents the lake. 

4. Select the Tools > Parameter Assignment  menu item.  We will be assigning a value of –1 to all 
cells within this polygon. 

5. Select Layer 7. Layer 1 IBOUND 

6. Click the radio button called Assign value , and enter a value of –1 to the box. 

7. In the Cell Selection Method , make sure Select cells within polygon(s)  is selected. 

 
8. Click Apply , and then select Yes to the window that pops up. 

9. To verify that these values have been assigned properly: 

i. Open the Data Parameter  window by selecting Project Data  > Data Parameter .  In the List 
tab, make sure there is a check beside Layer 1 IBOUND and close the Data Parameter  
window by clicking OK. 

ii. Select the Tools  > Parameter Browser  menu item to open the Grid Info  window. 

iii. Click on the plain arrow on the menu bar, and click on different locations in the grid.  The 
Grid Info  window will update with the current cell value (see the figure below).  The left 
column of cells should have a “-1” value, while the remainder of the grid should be set at a 
value of “1”. 
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Tutorial 19. Setting up the IBOUND array for Layer 2 – Step 1 

The IBOUND array for Layer 2 will be identical to that in Layer 1.  Thus, we simply need to repeat the 
steps from the previous section. 

1. Open the Project Manager. 

2. Highlight Data Parameter 7 and hit the  icon and select Add New Data Parameter .  Select 
No twice.  Click OK. 

3. Double-click on this new Parameter to open the Data Parameter window.   

4. In the Name tab, change the name to “Layer 2 IBOUND” in the Name window. 

5. In the Grid  tab: 

i. Select “15 x 15 MODFLOW grid” in the Link to grid  box. 

ii. In the File  box, enter a file name “Layer 2 IBOUND.grd”. 

iii. In the Format  box, select “Integer (2byte)”  (This is important!) 

iv. Click on Apply , then OK. 

6. Select Tools > Parameter Calculator . 

7. In the Equation  box, delete the equation that is shown, and type: PM(8)=1 

8. Select Execute  in the window that appears, and Yes to generate the new grid file. 

Tutorial 20. Setting up the IBOUND array for Layer 2 – Step 2 

Set left-most column of cells to –1 for Constant Head. 

1. Because we’ve already drawn a polygon that encompasses the left-most column of cells, we 
won’t have to draw a new one.  Select this polygon by select the menu item Edit > Select 
Objects , and click on the polygon.  VIEWLOG will outline the object with a thin dashed line. 

2. To assign values of –1 to cells within the selected polygon, select Tools > Parameter 
Assignment . 

3. Select Layer 8. Layer 2 IBOUND 

4. Click the radio button called Assign value , and enter a value of –1 to the box. 



Geostatistics and Modelling User’s Guide  �  58 

5. In the Cell Selection Method , make sure Select cells within polygon(s)  is selected. 

6. Click Apply , and then answer Yes to the window that pops up to re-generate the grid. 

7. To verify that these values have been assigned properly: 

i. Open the Data Parameter  window by selecting Project Data > Data Parameter .  In the List  
tab, make sure there is a check beside Layer 2 IBOUND and close the Data Parameter  
window by clicking OK. 

ii. Select Tools > Parameter Browser  to open the Grid Info window.   

iii. Click on the plain arrow on the menu bar, and click on different locations in the grid.  The 
Grid Info  window will update with the current cell value (see the figure below).  The left 
column of cells should have a “-1” value, while the remainder of the grid should be set at a 
value of “1”. 

Tutorial 21. Setting up the IBOUND array for Layer 3 

All cells in Layer 3 will be assigned a value of 1, indicating that all cells are active.  

1. Open the Project Manager. 

2. Highlight Data Parameter 8 and hit the  icon and select Add New Data Parameter .  Select 
No twice.  Click OK. 

3. Double-click on this new Parameter to open the Data Parameter window.   

4. In the Name tab, change the name to “Layer 3 IBOUND” in the Name window. 

5. In the Grid tab: 

i. Select “15 x 15 MODFLOW grid” in the Link to grid  box. 

ii. In the File box, enter a file name “Layer 3 IBOUND.grd”. 

iii. In the Format  box, select “Integer (2byte)”  (This is important!) 

iv. Click on Apply , then OK. 

6. Select Tools > Parameter Calculator . 

7. In the Equation  box, delete the equation that is shown, and type: PM(9)=1 

8. Select Execute  in the window that appears, and then Yes to generate the new grid file. 

5.6 -  Setting up the Initial Hydraulic Heads 
For each layer, the initial heads must be specified.  We will use VIEWLOG’s Data Parameter  window to 
set up the initial head array for each layer.  The initial heads will be the same for each layer, with a 
uniform head of 50 feet for each cell except for the left-most column of cells, where the initial head will be 
set to 0 feet.  Because we set this column of cells to be constant-head cells in the previous sections (for 
Layers 1 and 2), this value of 0 feet will be the constant-head value for Layers 1 and 2.  

Tutorial 22. Setting up the Initial Heads for Layer  1 
1. Open the Project Manager. 

2. Highlight Data Parameter 9 and hit the  icon and select Add New Data Parameter .  Select 
No twice.  Click OK. 

3. Double-click on this new Parameter to open the Data Parameter window.   

4. In the Name tab, call this new parameter “Layer 1 Initial Head” 
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5. Back in the List  tab, place a check in the box to the left of the new parameter, and make sure you 
are editing this parameter by highlighting it.  The new parameter should also appear in the 
Parameter Number  box at the top of the window. 

6. In the Grid  tab, link this new parameter to the “15 x 15 MODFLOW grid”, and name the grid file 
“Layer 1 Initial Head.grd” (Make sure you put the grid file into your working directory). 

7. Click on Apply , and then OK. 

8. To assign a constant value of 50 to the entire layer: 

i. Select Tools > Parameter Calculator . 

ii. In the Equation  window, delete the equation that currently exists.   

iii. From the Available Parameters  list, double click on the parameter called “Layer 1 Initial 
Head” 

iv. In the Equation  window, add “=50” to the end.  You should see: PM(10)=50 

v. Click Execute , then click Yes to create the grid. 

9. To assign a value of 0 to the left-most column of cells 

i. Select the polygon that was create previously.  Use the Edit > Select Objects  menu, and 
then click on the polygon that encompasses the left column of cells. 

ii. Go to the Tools > Parameter Assignment  menu item, and select the Layer 1 Initial Heads 
parameter 

iii. Make sure Parameter 10. Layer 1 Initial Head is selected at the top of the Parameter 
Assignment window 

iv. Turn on the radio button called Assign Value , and type 0 in the box. 

v. Click Apply , and then Yes to regenerate the grid. 

Tutorial 23. Setting the Initial Heads for Layer 2 

The procedure outlined above for Layer 1 can be repeated for Layer 2, because the initial heads will 
be the same.  Name the Data Parameter  “Layer 2 Initial Heads”, and call the grid file “Layer 2 Initial 
head.grd” in your working directory. 

Tutorial 24. Setting the Initial Heads for Layer 3 

Repeat the process for Layer 3, with the same initial heads as in Layers 1 and 2.  Use “Layer 3 Initial 
Heads” as the name for the new Data Parameter , and name the grid file Layer 3 Initial Head.grd” in 
your working directory. 

Save your work by selecting the File > Save  menu item. 

5.7 -  Setting up the Hydraulic Conductivity 
Arrays 
Hydraulic conductivity can be specified in a manner similar to that outlined above for initial head, or layer 
tops and bottoms.  To do this, you would have to set up a Data Parameter  for each layer.  This is the 
method that would be required if hydraulic conductivity was based on borehole data in a database.  You 
can also create a gridded Data Parameter  to represent variable hydraulic conductivity that is based on 
borehole information.   
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For this tutorial, however, because we will be assigning a constant value of hydraulic conductivity to each 
layer, we will use the MODFLOW Layer menu to illustrate another method of assigning constant values to 
a MODFLOW layer.  The procedure for this is illustrated in the following section. 

Tutorial 25. Setting up the Hydraulic Conductivity for Layer 1 

In VIEWLOG, the MODFLOW menu is used to assign properties to MODFLOW layers, create 
MODFLOW files, and run MODFLOW.  Up to this point, we have only created Data Parameters in 
VIEWLOG.   The next step will be to assign these and other parameters to MODFLOW layers. 

The MODFLOW Layer menu is used to link MODFLOW layer parameters to existing VIEWLOG Data 
Parameters.  This menu can also be used to assign constant values to MODFLOW layers.  This 
tutorial will set up a three-layer MODFLOW model and assign properties one layer at a time.  

1. Select the MODFLOW > MODFLOW Layer  menu item. 

2. Set the Name to “Layer 1” 

3. Because Layer 1 is the uppermost MODFLOW layer, set Layer Condition  to: Unconfined (read 
K) 

4. Set Anisotropy  to 1 

5. In Parameter Settings , set the following: 

i. Highlight the Hydraulic Conductivity  parameter, and set it to a constant value of 0.001 ft/s 
by selecting the Constant  radio button, and entering the value in the adjacent box (see 
below) 

 
ii. Highlight the Vertical Conductance  parameter and set it to constant 0.00000002 by 

selecting the Constant  radio button, and entering the value in the adjacent box. 

iii. In a similar manner, set Porosity  to a constant value of 0.2 

iv. Set Recharge  to a constant value of 0.00000003 
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v. Link Layer Top  to the parameter Layer 1 Top by selecting the Linked to Parameter  radio 
button and clicking on the Data Parameter  called “Layer 1 Top”, which we created 
previously. 

vi. In a similar manner, link Layer Bottom  to the Data Parameter  called “Layer 1 Bottom”. 

vii. Link Initial Head  to the Data Parameter called “Layer 1 Initial Head” 

viii. Link IBOUNDS to the Data Parameter called “Layer 1 IBOUND”. 

Tutorial 26. Setting up the Hydraulic Conductivity for Layer 2 
1. Click on the Add Layer  button to add a second layer.  Select Yes to replicate the settings of 

Layer 1. 

2. Make sure that Layer 2 is highlighted in the Layer Number  box at the top of the window. 

3. Name this layer “Layer 2”. 

4. Set the Layer Condition  to Confined/Unconfined (read Trans). 

5. Set Anisotropy  to 1 

6. Highlight Hydraulic Cond. Or Transmissivity .  In this case, we will be assigning a constant 
value for T of 0.01 ft2/s 

7. Set Vertical Conductance  to a constant value of 0.00000001. 

8. Set Porosity  to a constant value of 0.2 

9. Link Layer Top  to Layer 2 Top Data Parameter in a manner described in the previous section. 

10. Similarly, link Layer Bottom  to Layer 2 Bottom. 

11. Link Initial Head  to Layer 2 Init. Head. 

12. Link IBOUNDS to Layer 2 IBOUND. 

Tutorial 27. Setting up the Hydraulic Conductivity for Layer 3 
1. Click on the Add Layer  button to add a third layer.  Select Yes to replicate the settings of Layer 2. 

2. Make sure that Layer 3 is highlighted in the Layer Number  box at the top of the window. 

3. Name this layer “Layer 3”. 

4. Set the Layer Condition  to Confined/Unconfined (read T). 

5. Set Anisotropy  to 1 

6. Highlight Hydraulic Cond. Or Transmissivity .  In this case, we will be assigning a constant 
value for T = 0.02 ft2/s 

7. Set Vertical Conductance  to a constant value of 0.00000001 

8. Set Porosity to a constant value of 0.2 

9. Link Layer Top  to Layer 3 Top Data Parameter in a manner described in the previous section. 

10. Similarly, link Layer Bottom  to Layer 3 Bottom. 

11. Link Initial Head  to Layer 3 Init. Head. 

12. Link IBOUNDS to Layer 3 IBOUND. 

13. Click OK 

Save your MODFLOW work by selecting the MODFLOW > Save menu item.  In your working 
directory, call this file sample.mdf. 
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5.8 -  River/Drain Properties 
In this section, we will add a ditch to the top layer by using MODFLOW’s drain option.  In VIEWLOG, this 
is accessed by the MODFLOW > River/Drain Properties  menu item.  The first step in this procedure is 
to create a VIEWLOG layer that contains a line through the drain cells. 

Tutorial 28. Draw a line through the Drain Cells 
1. Open the VIEWLOG layer menu by selecting the Layer  menu item. 

2. To add a new layer, first highlight the highest-numbered layer on the list, and then click on the  
button within the Layer Control  window. 

3. Name this layer “Drain Centerline”.  Set this new layer to the Current Drawing Layer by right 
clicking on it, and selecting: Set to Current drawing layer. 

4. Move this layer down the list by first selecting it, and then clicking on the  button several times, 
until the “Drain Centerline” layer is at the bottom of the list, as shown below. 

 
5. The next step is to draw a polyline through the cells.  Start by clicking on the  icon. 

6. In the drawing window, use the mouse to click on the left-most cell of the “Little Ditch”.  Click 
again in the right most cell of the “Little Ditch”. 
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Tutorial 29. Adding a Drain to Layer 1 
1. Select the MODFLOW > River/Drain Properties menu item. 

2. Set the following: 

i. Name: Little Ditch 

ii. Type: Drain 

iii. Applied to MODFLOW Layer : 1 

iv. Drawing Layer Line Source : Drain Centerline 

3. Set the following Bed Properties : 

i. Width : 10 

ii. Thickness : 1 

iii. Conductance : 0.00002 

4. For Elevation Reference , place a check beside the box called Elevation Relative to:  and select 
the Data Parameter called Layer 1 Top. 

5. Click OK. 

 
6. You have now created a Drain along the Little Ditch.  As before, it is a good idea to save the 

MODFLOW project in VIEWLOG.  Click on MODFLOW > Save. 

5.9 -  The MODFLOW Control Menu 
The MODFLOW > MODFLOW Control  menu item is used to create data files, including River (and Drain) 
and Well files, and to run the MODFLOW simulation. 

Tutorial 30. Setting up the MODFLOW Control menu 
1. Select MODFLOW > MODFLOW Control   

2. For Title 1 , enter: Sample Problem for MODFLOW 

3. For Title 2 , enter: VIEWLOG TUTORIAL 

4. Type “Sample.lst” for the Output File  (Make sure you are in your working directory). 

5. Place a check beside the following MODFLOW Packages: 

i. Well  

ii. Drain  
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iii. Recharge  

iv. OC 

6. In the Stress Periods  section, make sure the Solution  is set to Steady State  

7. In the Solver  section, select the PCG solver. 

8. In the Geometry  section, set: 

i. Link to Grid : 1 

ii. Layers : 3 

9. In the Well Package  section, click Pumping  

i. Enter the following data in the table: 

Name                      Layer   X   Y     Period Rate 
PW-1 3 52500 52500 1 -5 
PW-2 2 27500 57500 1 -5 
PW-3 2 57500 47500 1 -5 
PW-4 1 37500 32500 1 -5 
PW-5 1 47500 32500 1 -5 
PW-6 1 57500 32500 1 -5 
PW-7 1 67500 32500 1 -5 
PW-8 1 37500 22500 1 -5 
PW-9 1 47500 22500 1 -5 
PW-10 1 57500 22500 1 -5 
PW-11 1 67500 22500 1 -5 
PW-12 1 37500 12500 1 -5 
PW-13 1 47500 12500 1 -5 
PW-14 1 57500 12500 2 -5 
PW-15 1 67500 12500 2 -5 

10. Click Close , and Yes to save the pumping data. 

11. Close the Modflow Control  menu. 

12. Select MODFLOW > Save to save your MDF file. 

Tutorial 31. Preparing Files for MODFLOW Output 
1. Open the MODFLOW > MODFLOW Layer  menu item. 

2. Click the Model outputs  radio button. 

3. Click Create result parameters for this layer .  This will create a Data Parameter  for each 
output type.  For this example, we’ll only need Potentials. (If you wish, you can go into the 
Project Data > Data Parameter  window later, and delete the parameters that you don’t need.) 

4. You should create Data Parameters for output for EACH layer.  In the MODFLOW Layer  menu, 
you can switch between layers by highlighting the desired layer in the box at the top of the 
window. 

Tutorial 32. Running MODFLOW 
1. Open the MODFLOW Control menu by selecting MODFLOW > MODFLOW Control . 

2. In the Create Model Input Files  section, click on the BCF, Well  and Stress  buttons to create 
these MODFLOW files.  The Stress  button will create a file for the River (in our case, Drain) cells. 

3. Run MODFLOW by clicking the MODFLOW button in the Run Model  section. 
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5.10 -  Visualizing Output 
Visualizing output from the MODFLOW simulation is simple.  As discussed previously, Data Parameters 
are created for the desired MODFLOW output.  In this tutorial, we will only need to visualize Potentials.   

Tutorial 33. Generating Output 

In this tutorial we will visualize potentials. 

1. Open the Project Manager, and double-click on the Data Parameter called: Layer 1 Potentials.  
The Data Parameter window will open. 

2. In the List  tab, turn ON Layer 1 Potentials by adding a check to the box 

3. In the Plan View  tab: 

i. Click Auto-Scale  to scale the contours 

ii. Turn on colour fill by checking the Show Solid Color Fill  box. 

iii. Click Apply .  You should see a colour map. 

 
4. To turn these contours off, uncheck the box on the List menu  

5. If desired, you can view Potentials on Layers 2 and 3 in the same manner. 
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